Extra call delay on the voice
Incident Report for Omnicus
Resolved
This incident has been resolved.
Posted Mar 06, 2021 - 16:00 CET
Investigating
Some calls have more that acceptable delay on the voice
Posted Mar 05, 2021 - 15:58 CET
This incident affected: Customer Channels (Voice).