Outgoing mail delay
Incident Report for Omnicus
Resolved
Mail was delayed, but queued for delivery. Delay has been solved, and all mail has been sent.
Posted Jan 31, 2022 - 08:50 CET
Investigating
We are currently investigating this issue.
Posted Jan 31, 2022 - 08:24 CET