Delayed mail delivery
Incident Report for Omnicus
Resolved
All mails should have been delivered now, and we are sending with normal speed again!
Posted Apr 25, 2023 - 15:21 CEST
Identified
We are working with our provider to resolve the issue. Mail does get delivered, but it might be delayed up to 10-20 minutes.
Posted Apr 25, 2023 - 14:20 CEST
This incident affected: Customer Channels (Outgoing mail).