Temporary mail delayed
Incident Report for Omnicus
Resolved
All mailings have now been dispatched with minimal interruption to the delivery schedule.
Posted Apr 10, 2024 - 13:30 CEST
Investigating
We are currently investigating this issue.
Posted Apr 10, 2024 - 13:19 CEST