SMS and Mail delays
Incident Report for Omnicus
Resolved
This incident has been resolved, and all unsent SMS and mails has been sent.
Posted Mar 18, 2022 - 11:17 CET
Investigating
We are currently investigating this issue.
Posted Mar 18, 2022 - 03:40 CET